Should we really use Clojure's syntax for namespaced keys?


Using entity_last_modified and person_name as general properties is what I was arguing for, and I would put the entity and the person in the key name rather than the namespace. You gave me the impression that you would always prefix them with employee in the namespace. What key name and namespace would you use for these properties?


After re-reading this I realized it is probably the reason I was not understanding why you would want to put the entity type into the keyword. I would solve this sort of problem differently by changing the name of obj to cust, or perhaps changing the function name to make it clear that it’s dealing with customers. It could also help to have an entity-type in maps to help with debugging, among other things, although of course it doesn’t help with reading the code.

Anyway, I do understand now why you’re doing this, and it may be the best thing for you.