Issue with clojure jira

I’m trying to report a Clojurescript issue but Jira is giving me the run around. I pressed the log in button at the bottom left and created an account through google. I then tried to create an issue using the plus button but was shown a dialog containing “You are not authorized to perform this operation. Please log in. Close this dialog and press refresh in your browser”. I tried refreshing and pressing the button again, but got the same message. I also pressed the log in button again, but that just causes the page to refresh, after which I got the same behavior from the plus button. I tried disabling cache as well.

Am I doing something wrong? Do we need permission from the core team to post issues on Jira?

You do need permission from an admin in order to create a Clojure JIRA account that has authorization to create or edit tickets.

I believe the recommendation is to create an issue on ask.clojure.org, which does not require permission from an admin, and Clojure admins responsible for identifying questions there they want to create Clojure JIRA tickets for, will do so if they think there ought to be a ticket to address it.

JIRA accounts are essentially reserved for folks who are working on patches these days (partly because of all the spam problems we were having). As Andy says, ask.clojure.org is the official way to report issues against Clojure, ClojureScript, and the Contrib libraries (it is persistent and searchable, via Google/Bing etc).

Just echoing Andy and Sean, the preferred process for reporting is documented at https://clojure.org/community/contributing#_reporting_problems_and_requesting_enhancements - filing a question at https://ask.clojure.org under the proper category with label “problem”. Once vetted, issues will be created in jira.

Jira accounts are reserved for those that are signed contributors and are working on patches (we are limiting these to preserve our limited number of accounts).

I miss the ability to “watch” the JIRA issues.

2 Likes

Thanks everyone for the info. I’ll post the issue on ask.clojure.