Problem with cli tools / deps.edn

I’m trying to use deps.edn and the cli tools for a new project, and I am getting a problem with a dependency. My deps.edn reads as follows:

{:paths ["resources" "src"]
 :deps {org.clojure/clojure {:mvn/version "RELEASE"}
        com.novemberain/monger {:mvn/version "3.1.0"}
        amperity/vaultclj {:mvn/version "0.7.0"}
        }
 :aliases
 {:test {:extra-paths ["test"]
         :extra-deps {org.clojure/test.check {:mvn/version "RELEASE"}}}
  :runner
  {:extra-deps {com.cognitect/test-runner
                {:git/url "https://github.com/cognitect-labs/test-runner"
                 :sha "76568540e7f40268ad2b646110f237a60295fa3c"}}
   :main-opts ["-m" "cognitect.test-runner"
               "-d" "test"]}}}

When I try to run a REPL, I get the following error:

 Error building classpath. Could not find artifact amperity:vaultclj:jar:0.7.0 in central (https://repo1.maven.org/maven2/)

It seems as though it’s not trying to fetch the library from clojars. I’ve also tried adding a mvn:repos key to deps.edn, like so:

:mvn/repos {"clojars" {:url "https://clojars.org/repo"}
            "central" {:url "https://repo1.maven.org/maven2/"}}

but it sill gives the same error.

If I try to use the vault-clj dependency from a Leiningen project, it just works as expected.

Any ideas of what I’m doing wrong here?

Replacing vaultclj with vault-clj made it work on my system.

1 Like

Thanks, @andy.fingerhut!