Very slow repl startup - Macbook with M1 chip to blame?

Hello,

I’ve got the new Macbook with M1 chip, and I restored my projects/files from Time Machine from my other macbookpro, and all just seems to work, but… somehow my lein repl command now takes forever.

Some smaller projects work, but my main large project i’m working on now is slow.

No idea if this has anything to do with the M1 architecture / Rosetta (if that applies at all), but anybody here with similar experience?

I tried lein clean, but to no avail. Any pointers would be great!

edit: other projects seem ok, speed wise. It’s just this one project, so I guess what I’m asking is: how can I profile this? :slight_smile:

edit2: switching to deps.edn speeds things up massively. Does this make sense? Well I guess it’s time to switch then :slight_smile:

1 Like

ok switching to deps.edn solved it. So it’s probably something totally unrelated. Maybe even going back to lein would work. Closing.

Lein uses maven right? So maybe removal of .m2/repository will help?

1 Like