What is this functionality of emacs/Doom/evil/cider of keeping prompting "Lisp expression:" when typing in evil input mode?

I sometimes accidentally run into some nuisance when in the input mode of evil mode with Clojure mode,
I’m kept prompted at the mini-buffer “Lisp expression:” that I don’t know what to do with it. I tried to enter some text, or Lisp expression, but I still get the same prompt without any helpful feedback, not able to do anything meaningful, useful. I want to know from which mode/package does this come from, so that I can disable it or remove this uninvited intrusion.

I’m using emacs/Doom, with a copied customization that I don’t fully know. It has Clojure mode, cider running at the buffer. There might be more running that I don’t know.

The problem might be related to “lispy.clojure”, as I saw an error message of

"  Syntax error compiling at (src/yubrshen/eta_variances.clj:1:1).
No such var: lispy.clojure/pp"

Please advise how I troubleshoot the problem.

1 Like

You can try disabling the “lispy” layer in doom-emacs (in the init.el file).

1 Like

I have the same issue. From time-to-time, I get in this state.

Disabling lispy cannot be a solution, as I want to use lispy.

1 Like

I had the same issue until I disabled the lispy layer.

It might be worth raising this as an issue on doom-emacs or on lispy’s github if you want to use lispy.

I realized later that disabling lispy “layer” in doom-emacs init.el does not solve the issue.
It still came back by some unknown keys. I’d like to trace where it’s enabled.
Even, I manually disable lispy-mode, it would still come back.

Just making sure - did you call doom/reload or run doom sync after removing the lispy layer?

1 Like

You might be right. I indeed forgot to do doom sync after commenting out the lispy feature in init.el
It seems this time, all functions of lispy have been disappeared.

I realize that I still want to use lispy.
In case, if you have any clue when and how one can be trapped in the state of “Lisp expression:” prompt at the minibuffer, please share.

It seems that it only occur when I’m in input mode of evil and typing a symbol name.

@Carsten_Behring and @mjmeintjes are you using emacs-doom (maybe lispyville.el) with lispy.el?
I’m trying to find the corresponding source code for the behavior of keep prompting “Lisp expression:”.

I did find a few places of (read-string…) function call, that might be the source in lispy.el.
but I found none of read-string in lispyville.el

I also check (interactive “p”…) in both modules, and found none plausible.

I’m currently trying out Symex as a replacement for lispy, as it seems much simpler without losing power.

https://countvajhula.com/2021/09/25/the-animated-guide-to-symex/

If I remember correctly, I have encountered a similar problem - I use lispy too and can’t quite give it up. I can’t quite emulate the problem at the moment to verify, but when I last dug, it led me to the company-capf function being triggered

@zackteo Yes, it involves a failure with company-capf.
lispy.el is a powerful Lisp editing machine, otherwise.

@mjmeintjes Thanks!
During the Christmas holiday, I finished and annotate the lispy.el demo on Youtube.
Here is demo with my annotation in the comment section:

lispy is actually very powerful and sensible Lisp editing machine, if this disturbance can be avoided.

1 Like

I raised an issue at lispy’s repo:

I’ve taken a look at symex.el. I like it being conceptually clean.
But I find the extra mode of symex a hurdle in addition to the evil’s normal mode, and input mode.
I’d rather have lispy to help in the input mode.

I had the same feeling about Symex. I think the author uses it along with Rigba, which is a system for changing the modal modes “tower”. So instead of escaping insert mode and going to normal MODE (INSERT → NORMAL) , you add a Symex mode in between, so you get INSERT → SYMEX → NORMAL.

I’m still working on setting this up and seeing if it works for me, will post my findings.

1 Like

The author of lispy.el has provided a fixed to the reported problem. But I have not yet figured out how to try it:

1 Like

I have it as well with Doom Emacs.
I would like to test it as well, but I am not sure when/how Doom emacs pulls in a new version of lispy

Wow! Awesome!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.